Войти Зарегистрироваться

Как создать календарь в программе Microsoft Excel?

Нужно отметить что для программы Excel существует ряд онлайн-шаблонов с помощью которых можно получить календарь в этой программе, примерно также как это показано в статье "Как сделать новогодний календарь в программе Microsoft Word?" , но мы предлагаем вам создать универсальный календарь самостоятельно. Для этого необходимо лишь немного знаний в области создания формул и форматирования ячеек книги Excel.


Обычно календарная сетка не что иное, как особым образом отформатированная таблица данных. Пусть в заголовках столбцов отображаются полные или сокращенные названия дней недели (получить их можно при помощи метода протягивания). Количество дней в любом из месяцев ограничено, поэтому будет достаточно шести дополнительных строк для размещения дат всех дней указанного месяца любого года. Однако следует учесть, что каждая дата должна располагаться в столбце, обозначающий день недели, на который она выпадает. В Excel существует немало полезных функций по работе с датой и временем.


Пошаговая технология создание календаря в программе Excel

  • Создать на отдельном листе вспомогательную таблицу размером 6 строк на 7 столбцов, в которой нужно слева направо разместить цифры от 1 до 42.

Как создать календарь, в программе, Microsoft Excel,


  • Под таблицей создаем вторую вспомогательную таблицу этого же размера, поместив в каждую ячейку формулу


=Нм + ДАТА(Гд,Мс,1) - ДЕНЬНЕД(ДАТА(Гд,Мс,1);2)


Поясним смысл формулы:

ДЕНЬНЕД – встроенная функция Excel, которая возвращает для указанной даты её день недели,
Нм –относительная ссылка на 1-ую ячейку 1-ой вспомогательной таблицы,
ДАТА – функция возвращающая дату, которая выпадает на первый день указанного месяца выбранного года. Её аргументами являются: Гд - ссылка на ячейку где находится год, Мс - ссылка на ячейку с числом месяца.
  • В таблицу на основном листе для создания календарной сетки заносятся формулы, которые не отображают даты, принадлежащие предыдущему и следующему месяцу:

=ЕСЛИ(МЕСЯЦ(Дт) = Мс; Дт;"")

где:
МЕСЯЦ – встроенная функция Excel, которая возвращает месяц из указанной даты,
Мс - ссылка на ячейку месяца,
Дт - ссылка на ячейку 2-ой вспомогательной таблицы (в которой вычислены даты месяца),

Как создать календарь, в программе, Microsoft Excel,


Для нашего примера формула первой ячейки второй вспомогательной таблицы имеет следующий вид:

=A3 + ДАТА($A$1;$B$1;1) - ДЕНЬНЕД(ДАТА($A$1;$B$1;1);2)


  • Формат ячеек таблицы календарной сетки задаем таким образом, чтобы отображались только числа месяца. Для этого в диалоговом окне "Формат ячейки" на вкладке "Число" выбираем пункт "Все форматы", а в строке справа набираем символ Д.


Как создать календарь, в программе, Microsoft Excel,


А формула первой ячейки основной таблицы в нашем примере имеет вид :

=ЕСЛИ(МЕСЯЦ(Лист2!A12) = 11; Лист2!A12;"")


Как видите все достаточно просто и легко, если знаешь как работать с формулами в Excel! Наш календаря можно легко преобразовать в настольный заменив конкретный год и месяц на формулы для их вычисления из текущей даты. Также меняя всего две цифры можно создать все 12 месяцев. И скопировать их в Microsoft Word или оформить их аккуратно на одном из чистых листов книги Excel.



Примечание. Для добавления формул в другие ячейки таблиц используем метод протягивания (копирования формул). Скачать готовый пример календарной сетки на месяц в Excel


<<< Как сделать новогодний календарь в программе Microsoft Word? Как создать календарь при помощи программы TKexe Kalender? >>>